Instability with Cards Service
Incident Report for Pomelo
Resolved
There was a delay processing card batches. Service has been normalized
Posted Oct 10, 2024 - 17:57 GMT-03:00
Investigating
We are currently investigating this issue.
Posted Oct 10, 2024 - 16:38 GMT-03:00