Problems with transaction service
Incident Report for Pomelo
Resolved
We are reviewing the affected transactions during the incident window. If your account was impacted, we will contact you directly with further details and any necessary adjustments.

Thank you for your patience and understanding. If you have immediate concerns, please reach out to our support team.
Posted Jan 13, 2025 - 16:33 GMT-03:00
Monitoring
We identified a discrepancy in the USD conversion rates for Mexico and Brazil. A workaround has been implemented to mitigate the impact.

The situation is being closely monitored.
Posted Jan 13, 2025 - 14:15 GMT-03:00
This incident affected: Mastercard Network, Visa Network and MX (Prosa Network).