Degradation in Fraud Services

Incident Report for Pomelo

Resolved

Corrective actions were applied and service has now been restored for Fraud Services. We will continue to monitor the component closely.
Posted Apr 11, 2026 - 15:22 GMT-03:00

Investigating

We are currently experiencing degradation in the Fraud Services component. Our team is actively investigating the issue and working to restore normal service as soon as possible. We will share another update as soon as we have more information.
Posted Apr 11, 2026 - 15:17 GMT-03:00
This incident affected: Fraud Services.