Instability with Cards Service
Incident Report for Pomelo
Resolved
Incident was identified and resolved.
Posted Sep 10, 2024 - 00:24 GMT-03:00
Investigating
We are currently investigating this issue.
Posted Sep 09, 2024 - 23:59 GMT-03:00