Instability with Mastercard Network

Incident Report for Pomelo

Resolved

The service has been fully restored and is functioning normally.
Posted Mar 10, 2026 - 10:10 GMT-03:00

Monitoring

A fix has been implemented and we are monitoring the results. We are closely monitoring the service to ensure complete stability.
Posted Mar 10, 2026 - 10:06 GMT-03:00

Investigating

We are investigating connectivity errors with our 3DS provider, resulting in possible rejection of 3DS transactions with challenge (OTP)
Posted Mar 10, 2026 - 09:34 GMT-03:00
This incident affected: Mastercard Network and Visa Network.