Instability with Cards Service

Incident Report for Pomelo

Resolved

Service was restored
Posted Oct 09, 2024 - 17:57 GMT-03:00

Investigating

We are currently investigating this issue.
Posted Oct 09, 2024 - 17:38 GMT-03:00