Instability with Cards Service
Incident Report for Pomelo
Resolved
Instability in Cards Service solved
Posted Aug 21, 2024 - 09:09 GMT-03:00
Investigating
We are currently investigating this issue.
Posted Aug 20, 2024 - 17:42 GMT-03:00