Instability with Embossing Service
Incident Report for Pomelo
Resolved
The Nov 6th embossing process was delayed due to an internal error.
The process was rescheduled at 12 AM(UTC) and completed.
Posted Nov 06, 2024 - 09:27 GMT-03:00
Investigating
We are currently investigating this issue.
Posted Nov 06, 2024 - 08:19 GMT-03:00