Instability with Cards Service

Incident Report for Pomelo

Resolved

Incident was identified and resolved
Posted Aug 22, 2024 - 00:32 GMT-03:00

Investigating

We are currently investigating this issue.
Posted Aug 21, 2024 - 22:59 GMT-03:00