Instability with Mastercard Tokenization Service

Incident Report for Pomelo

Resolved

Issuing of Mastercard payment tokens has been restored. Between 7:30 AM and 3:50 PM (GMT-3) the outage affected issuance of new tokens. Root cause has been identified and solved
Posted Apr 24, 2025 - 16:23 GMT-03:00

Update

We are actively working with Mastercard to investigate and resolve the issue.
Posted Apr 24, 2025 - 14:22 GMT-03:00

Update

We are continuing to investigate this issue.
Posted Apr 24, 2025 - 13:03 GMT-03:00

Investigating

It appears that the issue may be related to a recent change in Mastercard’s outbound certificates. Our team is actively investigating this as a possible contributing factor.

Only Mastercard tokenization activations are currently impacted. Other token-based transactions are operating normally.

We’re in ongoing communication with Mastercard to better understand the root cause and expected timeline for resolution.
Posted Apr 24, 2025 - 11:54 GMT-03:00

Identified

We are currently experiencing a partial outage affecting the issuing of new payment tokens for Mastercard payment cards. Existing tokens remain functional, and all other services are operating as expected.
Posted Apr 24, 2025 - 10:23 GMT-03:00

Investigating

We are currently investigating an instability affecting our services
Posted Apr 24, 2025 - 09:51 GMT-03:00
This incident affected: Mastercard Tokenization Service.