Instability with our services
Incident Report for Pomelo
Resolved
The issue has been identified and resolved. None of our systems were affected
Posted Sep 27, 2024 - 03:24 GMT-03:00
Investigating
We are currently investigating this issue.
Posted Sep 27, 2024 - 02:53 GMT-03:00