Pomelo Service Disruption Due to Cloudflare Outage

Incident Report for Pomelo

Resolved

This incident has been resolved.

Earlier today, our services were affected by an incident with our CDN and edge networking provider, Cloudflare, which resulted in intermittent errors, slow responses, or timeouts for some users.

Cloudflare has fully mitigated the underlying issue and our systems have remained stable since. We are no longer observing elevated error rates or latency and all functionality is operating normally.

We will continue to monitor our platform closely, and we are reviewing this event with our provider to help prevent similar issues in the future.

Thank you for your patience while we worked through this incident.
Posted Nov 18, 2025 - 17:57 GMT-03:00

Monitoring

Cloudflare has implemented fixes and we are monitoring the recovery of Pomelo services.

We will continue to monitor closely and provide updates as the situation progresses.
Posted Nov 18, 2025 - 12:47 GMT-03:00

Update

Some Pomelo services are beginning to stabilize, though users may still experience intermittent issues as recovery continues across Cloudflare's network.

We continue to monitor the situation and will provide another update shortly.
Posted Nov 18, 2025 - 11:02 GMT-03:00

Identified

We have identified the root cause of the service disruptions affecting Pomelo. The issue is due to an ongoing Cloudflare infrastructure outage that is impacting multiple services across their network.

Our team is in contact with Cloudflare support and monitoring their status page for updates on their remediation efforts.

We will continue to provide updates as the situation progresses.
Posted Nov 18, 2025 - 09:33 GMT-03:00

Investigating

We are currently investigating this issue.
Posted Nov 18, 2025 - 09:06 GMT-03:00
This incident affected: General APIs (Cards Service, Users Service, Dashboard Service, Core Services, Embossing Service, Shipping Service), Pomelo Website, Developer Website, BR (Identity Service), and ARG (Identity Service).